Parallel-Installation


Startseite Foren Hilfe bei Problemen Parallel-Installation

Verschlagwortet: , ,

9 Beiträge anzeigen - 1 bis 9 (von insgesamt 9)
  • Autor
    Beiträge
  • #4117
    Snoopy57
    Teilnehmer

    Guten Tag zusammen,

    ich habe lange mit mir gekämpft, ob es ich wagen soll. Schließlich aus diversen Gründen entschieden, nicht die vorhandene 1.10-Version zu aktualisieren, sondern eine neue Installation testweise parallel aufzusetzen.

    Vorgehen (MAC High Sierra, feste IP):

    Datensicherung
    Separates Verzeichnis auf zweitem Laufwerk eingerichtet
    Start Server-Installation
    Einrichtung als Dienst
    In der Abfrage ein separates Programmverzeichnis an Zielverzeichnis angegeben
    vorhandene SQL-Zugangsdaten gewählt
    Installation abgeschlossen

    Client-Installation
    separates Zielverzeichnis w.o. angegeben

    Beide Installationen scheinbar fehlerfrei abgeschlossen

    Ergebnis:
    Kontakt zu Server
    separates Programmverzeichnis leer
    Offenbar wurde ein Mix aus alter und neuer Installation im Haupt-Programmverzeichnis des Rechners erstellt
    Kein Login möglich, weder mit admin/a user/u noch mit den Anmeldedaten der alten Installation
    Die alte Installation ist offenbar „verschwunden“

    Ich glaube, ich hätte es lassen sollen… 😉

    #4118
    j-lawyer.org
    Verwalter

    Da wäre ein Kontakt vorab sinnvoll gewesen 🙂

    Gibt es eine Datensicherung der ersten Installation?

    Eine Parallelinstallation ist technisch möglich, aber aus vielerlei Hinsicht anspruchsvoll:

    • Netzwerkkonfiguration muss angepasst werden, da der Serverdienst ja auf mehreren Ports lauscht
    • Auch wenn unterschiedliche Installationsverzeichnisse verwendet werden, so „treffen“ sich beide Installationen auf der MySQL-Datenbank.
    • Die Dienstkonfiguration (auf macOS ein sogenannter LaunchDaemon) muss doppelt mit unterschiedlichen Konfigurationen erstellt werden
    • uvm.

    Mein Favorit wäre definitiv ein Update gewesen, von 1.10 sollte das gar kein Problem sein.

    Grüße
    Jens / j-lawyer.org

    #4119
    Snoopy57
    Teilnehmer

    Sehr schön, nur wenn ich jetzt die derzeitige Installation lösche, lösche ich vermutlich alles.
    Also nochmal eine Installation starten und dann als Update laufen lassen, über das jetzt Vorhandene drüber?
    Es gibt eine Datensicherung der ersten Fassung vor der heutigenNeuinstallation

    • Diese Antwort wurde vor vor 1 Monat, 2 Wochen von Snoopy57 bearbeitet.
    #4121
    j-lawyer.org
    Verwalter

    Nochmal die Frage: hast Du ein Backup (inklusive Datenbank-Dump) der alten Installation?

    Für einen fundierten Rat fehlt mir schlicht der Istzustand des Systems. Evtl. gar komplett alles wegwerfen, 1.13 installieren, dann Rücksicherung aus dem Backup der 1.10. Beim Start der 1.13 erkennt die Anwendung den alten Stand der Datenbank und aktualisiert ihn vollautomatisch.

    #4122
    Snoopy57
    Teilnehmer

    Ja, habe ein Backup der alten Installation über „Jetzt sichern“ gemacht, liegt wohl in einem Unterverzeichnis im Programmordner.Bevor ich alles wegwerfe, müsste ich wissen, wo und welche Dateien ich sichern muss. Den ganzen Verzeichnisbaum „backups“ vermutlich sichern….?

    #4123
    j-lawyer.org
    Verwalter

    Ja, backups brauchst Du. Ich hoffe das Datenbankpasswort war in den Sicherungseinstellungen korrekt hinterlegt. Im backups-Verzeichnis muss es eine jlawerdb-dump.zip o.ä. geben, dort sollte eine .sql – Datei drin sein, mit Inhalt. Ist die Datei leer, war das Backup nicht richtig konfiguriert. (falsches oder leeres Datenbankpasswort)

    #4124
    Snoopy57
    Teilnehmer

    OK, ich mache das morgen und gebe dann Rückmeldung, wie es lief. Jetzt Chillout 😎
    DANKE!

    #4125
    Snoopy57
    Teilnehmer

    Hallo,
    bin jetzt wie beschrieben vorgegangen:

    (nach Sicherung Backup) Komplett-Deinstallation
    Neustart
    Neuinstallation – keine Fehlermeldungen
    Test: Dienst läuft
    Anmeldung: es wird der alte Anmeldename im Feld Benutzer angezeigt
    Anmeldung weder mit altem Anmeldenamen + PW noch mit admin/a bzw. user/u möglich

    #4126
    j-lawyer.org
    Verwalter

    Wie verifierst Du „Dienst läuft“?

    Und bitte ein server.log an die Mailadresse im Impressum.

9 Beiträge anzeigen - 1 bis 9 (von insgesamt 9)
  • Du musst angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.