Anmeldedaten oder Verbindungsparameter falsch nach Neuinstallation


Startseite Foren Installation Anmeldedaten oder Verbindungsparameter falsch nach Neuinstallation

Verschlagwortet: ,

7 Beiträge anzeigen - 1 bis 7 (von insgesamt 7)
  • Autor
    Beiträge
  • #6049
    so
    Teilnehmer

    Hallo zusammen,
    ich habe wieder mal ein lästiges Problem – irgendwo ist der Wurm drin, ich weiß nur nicht wo; daher werde ich meine Installationsschritte so ausführlich wie möglich schildern.

    Meine Grundkonfiguration schaut wie folgt aus:
    1. j-lawyer-server läuft auf PC1 mit Ubuntu als OS
    2. j-lawyer-client läuft auf PC2 mit Win11 als OS

    Ich habe bisher die Version j-lawyer 2.5 ohne Probleme genutzt. Nach dem Update von Server und Client auf 2.6 konnte ich mich nicht mehr in j-lawyer einloggen. Der Grund war, dass ich während des Uupdateprozesses das MySQL-Passwort fehlerhaft eingetragen hatte.
    Nun ja seitdem habe ich die Fehlermeldung: Anmeldedaten oder Verbindungsparameter falsch“ erhalten.
    Da ich das Problem nicht mit erneutem Start des Updateprozesses und Eingabe des richtigen Passwortes lösen konnte, habe ich mich dazu entschlossen den Server neu aufzusetzten.

    I.
    D.h. ich habe
    1.) auf PC1 Ubuntu neu installiert
    2.) den j-lawyer-client entsprechend der Anleitung neu aufgesetzt, dh:
    a.) sudo apt install mariadb-server mariadb-client
    b.) sudo systemctl start mariadb
    c.) sudo systemctl enable mariadb
    d.) sudo mysql_secure_installation
    Testweise habe ich mich dann mit sudo mysql -u root -p erfolgreich eingeloggt.
    e.) chmod a+x j-lawyer-server_unix_x_y.sh
    f.) sudo ./j-lawyer-server_unix_x_y.sh
    Damit den Installationsprozess gestartet und erfolgreich abgeschlossen.
    3.) auf PC2 den j-lawyer-client zunächst deinstalliert und dann erneut installiert.
    4.) SSH-Tunnel im Client-Profil eingetragen
    5.) Fehlermeldung, dass Anmeldedaten oder Verbindungsparameter falsch sind.

    II.
    Dann ist mir eingefallen, dass im Installationsprozess noch openjdk-11-jdk installiert werden musste (warum wurde dieser Schritt in der Installationsanleitung entfernt??) Naja Ergebnis des ganzen: erneut Fehlermeldung (Anmeldedaten oder und Verbindungsparameter falsch)

    III.
    Nach längerem Grübeln ist mit eingefallen, dass ich in der Fritzbox eine Freigabe hätte machen müssen, damit PC1 und PC2 untereinander kommunizieren können.
    Dh. ich habe bin wie I. vorgegangen und habe dann die Freigabe für PC1 in der Fritzbox als „exposed host“ hinterlegt und damit PC1 komplett für den Internetzugriff über IPv4 freigeben (testweise)
    Ergebnis: Fehlermeldung (Anmeldedaten oder Verbindungsparameter falsch)

    IV.
    Vorgehensweise wie in II. und Freigabe von PC1 als exposed host: Fehlermeldung (Anmeldedaten oder Verbindungsparameter falsch).

    V.
    Nunmehr bin ich mit meinem Latein am Ende. Welche Vorgehensweise ist denn überhaupt richtig. Dann könnte ich ggf. die Server.log zuschicken.

    Noch als Hinweis: PC1 hat immer eine feste IP erhalten; bspw. 192.168.178.160. Wenn ich nun im Browser auf PC2 „192.168.178.160:8080“ oder „localhost:8080“ eintippe, komme ich auf ordnungsgemäß auf die Hinweisseite von Wildfly.

    • Dieses Thema wurde vor vor 3 Wochen, 2 Tage von so bearbeitet.
    #6051
    j-lawyer.org
    Administrator

    Eine Neuinstallation ist meist kontraproduktiv, weil man gar nicht mehr einsehen kann was eigentlich das Problem war.

    Bitte mal das Server.log per Mail schicken.

    Viele Grüße
    Jens / j-lawyer.org

    #6052
    so
    Teilnehmer

    Die Mail mit der Server.log-Datei habe ich verschickt. Vielen Dank vorab!

    #6053
    j-lawyer.org
    Administrator

    Es müsste wie folgt vorgegangen werden:

    – Dienst stoppen
    – dieses Statement auf der Datenbank ausführen:

    update flyway_schema_history set success=1 where version=’1.12.0.8′;

    – Dienst neu starten

    Danach sollte ein Login möglich sein.

    VG
    Jens / j-lawyer.org

    #6054
    so
    Teilnehmer

    Vielen Dank, nur leider funktioniert es bei mir nicht.

    Wenn ich das o.g. Statement einfüge erhalte ich folgende Fehlmeldung: ERROR 1046 (3D000): No Database selected. Und wenn ich vorher „use jlawyerdb;“ eintippe, dann erhalte ich die Fehlermeldung ERROR 1046 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‚.8‘ at line 1

    #6055
    j-lawyer.org
    Administrator

    Es sind zwei separate Befehle, erst das use, mit Enter bestätigen, dann das update, mit Enter bestätigen.

    VG!

    #6060
    so
    Teilnehmer

    Danke für die Rückmeldung. Das es zwei separate Befehle sind hatte ich bereits beachtet.

    Die Auflösung des Problems: Ich habe einfach den Code kopiert und eingefügt. Das Problem waren die Anführungszeichen im Befehl. Das Abtippen des Codes mit den korrekten Anführungszeichen [‚<-auch dieses Anführungszeichen muss oben sein(..)‘ statt ’(..)′] und ein Neustart haben geholfen. VIELEN DANK!

    • Diese Antwort wurde vor vor 3 Wochen, 1 Tag von so bearbeitet.
    • Diese Antwort wurde vor vor 3 Wochen, 1 Tag von so bearbeitet.
7 Beiträge anzeigen - 1 bis 7 (von insgesamt 7)
  • Du musst angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.