Probleme mit der E-Mail-Einbindung


Startseite Foren Hilfe bei Problemen Probleme mit der E-Mail-Einbindung

Verschlagwortet: , , , , ,

15 Beiträge anzeigen - 1 bis 15 (von insgesamt 15)
  • Autor
    Beiträge
  • #3860
    socram
    Teilnehmer

    Moin,

    seit heute kann ich weder E-Mails per IMAP abrufen noch per SMTP versenden. Als Fehlermeldung erhalte ich hier nur „Keine Verbindung zum Mailserver: Remote host closed connection during handshake“ (bei IMAP). Beim Versenden per SMTP gibt es „Fehler beim Senden: Could not connect to SMTP host: smtp.mailbox.org, port: 465“

    Die Zugangsdaten sind korrekt (ich habe sie sicherheitshalber überprüft). Ebenfalls korrekt ist der Port für IMAP und SMTP. Im Thunderbird ist die Konfiguration identisch, ebenso unter Android mit Fairmail. Es funktioniert mit den anderen Clients völlig einwandfrei.

    Das Log habe ich an info@j-lawyer.org geschickt.

    Ich gehe stark davon aus, dass es mit der Abschaltung von TLS 1.0 und 1.1 bei mailbox.org zusammenhängt, was heute umgesetzt wurde.

    Hier wäre natürlich super, wenn man j-lawyer TLS 1.2 oder 1.3 beibringen könnte. Wenn ich in irgendeiner Form unterstützen kann, mache ich das gerne.

    #3862
    j-lawyer.org
    Verwalter

    Im Verzeichnis des Clients liegt eine .vmoptions – Datei, dort mal

    -Dhttps.protocols=TLSv1.2

    eintragen, Client neu starten und testen.

    #3863
    j-lawyer.org
    Verwalter

    PS: Die von einem Server unterstützten Protokollversionen lassen sich wie folgt prüfen:

    openssl s_client -connect imap.mailbox.org:143

    #3864
    socram
    Teilnehmer

    Vielen Dank für die schnelle Rückmeldung.

    Das hilft leider nicht weiter. Die Zeile habe ich ergänzt und testweise auch einmal TLSv1.3 probiert, was aber leider auch nicht geholfen hat.

    Danke auch für den OpenSSL-Tipp. Da sagt mir imap.mailbox.org auf Port 993, dass 1.3 unterstützt wird. Mit dem Parameter -tls1_2 meldet er aber auch zurück, dass TLS 1.2 geht.

    Auf 143 gibt es Fehler bei der Rückmeldung:

    openssl s_client -connect imap.mailbox.org:143
    CONNECTED(00000005)
    139647839490496:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../ssl/record/ssl3_record.c:332:

    no peer certificate available

    No client certificate CA names sent

    SSL handshake has read 5 bytes and written 318 bytes
    Verification: OK

    New, (NONE), Cipher is (NONE)
    Secure Renegotiation IS NOT supported
    Compression: NONE
    Expansion: NONE
    No ALPN negotiated
    Early data was not sent
    Verify return code: 0 (ok)

    Aber auch hier geht es dann mit dem Parameter -tls1_2.

    #3865
    j-lawyer.org
    Verwalter

    Bitte mal mit dieser genannten Änderung im Client die Administratorkonsole starten und

    sysprops

    eingeben. Dort dann die Zeile mit

    https.protocols

    suchen und hier posten. Den Rest bitte nicht.

    #3866
    socram
    Teilnehmer

    Moin,

    da steht die richtige Version:
    https.protocols = TLSv1.2

    Dennoch besteht sowohl beim Senden als auch beim Empfangen die Fehlermeldung weiter.

    #3867
    j-lawyer.org
    Verwalter

    Okay, dann bitte nochmal in der .vmoptions das hier setzen:

    -Djdk.tls.client.protocols=TLSv1.2

    und über die sysprops prüfen ob es aktiv ist. Dann erneut testen und hier posten.

    #3868
    socram
    Teilnehmer

    Auch das habe ich gemacht:

    sysprops bestätigt, dass es gesetzt wurde:
    jdk.tls.client.protocols = TLSv1.2

    Aber leider keine Besserung.

    #3870
    j-lawyer.org
    Verwalter

    Dann kann ich nur noch helfen wenn ich es direkt debuggen kann. Gibt es die Möglichkeit dass Sie mir einen temporären Testaccount dort anlegen?

    #3871
    j-lawyer.org
    Verwalter

    Dann kann ich nur noch helfen wenn ich es direkt debuggen kann. Gibt es die Möglichkeit dass Sie mir einen temporären Testaccount dort anlegen?

    #3874
    socram
    Teilnehmer

    Einen temporären Testaccount bei Mailbox.org meinen Sie? Bei Mailbox.org kann man sich einen kostenlosen Testaccount anlegen lassen.

    #3875
    j-lawyer.org
    Verwalter

    Ich habe das Problem analysiert und eine Anpassung vorgenommen: https://github.com/jlawyerorg/j-lawyer-org/issues/872

    Ich werde dafür kein extra Release veröffentlichen, sondern im normalen Zyklus mit der kommenden Version 1.13.

    Bitte wie folgt verfahren:

    – im Unterverzeichnis „lib“ des Clients liegen Dateien mail.jar, mailapi.jar, smtp.jar, imap.jar – diese vier Dateien bitte löschen
    – die neue Datei mail.jar herunterladen und in das lib-Verzeichnis des Clients legen: https://www.j-lawyer.org/temp/mail.jar

    Dann erneut testen und Rückmeldung geben.

    Ein Hinweis: sofern ein mailbox.org-Account auch für die Überwachung des Servers verwendet wird (Menü Einstellungen – Servermonitoring), wird dieser Teil der Anwendung bis zur 1.13 nicht funktionieren. Beim Server ist das Austauschen der Bibliothek auch leider nicht ganz so einfach.

    Beste Grüße,
    Jens
    (j-lawyer.org)

    #3876
    j-lawyer.org
    Verwalter

    Korrektur: der Server hat schon die Mailbibliotheken mit TLSv1.2-Unterstützung. Alles paletti.

    #3877
    socram
    Teilnehmer

    Moin,

    gleich umgesetzt und es läuft alles, wie es soll.

    Vielen lieben Dank!

    Zur Info: Bei mir gab es keine mailapi.jar.

    #3878
    j-lawyer.org
    Verwalter

    Danke für die Rückmeldung.

    Grüße,
    Jens
    (j-lawyer.org)

15 Beiträge anzeigen - 1 bis 15 (von insgesamt 15)
  • Du musst angemeldet sein, um zu diesem Thema eine Antwort verfassen zu können.